10415

API

Last updated: Mar 3rd, 10:31am

Overview

Returns from the following NVP/SOAP APIs:

  • DoExpressCheckoutPayment
  • DoUATPExpressCheckoutPayment
  • SetExpressCheckout

Cause

The error occurs when a successful PayPal transaction has already been created by consuming the Express Checkout token being used in the API request.

This error indicates that the request is a duplicate, and the requested action has already been completed.

This can happen if the merchant did not record the response of the DoExpressCheckoutPayment API call and made the same request again.

This can also happen if there was increased network or system latencies leading to the merchant recording a timeout on their end when the request completed successfully on the PayPal side.

Impact

The payment is completed, so there is no negative impact. However, the merchant's database is likely out of sync with the order statuses in PayPal.

Resolution

  • Get transaction details: The merchant can retrieve transaction details by making the GetExpressCheckoutDetails API call with the Express Checkout (EC-) token to get the transaction information, including the Transaction ID.
  • Enable notifications: The merchant can enable Instant Payment Notifications or webhooks with PayPal to receive instant status updates via HTTP post calls to merchant servers. This helps keep the merchant in sync with PayPal's latest payment statuses and prevents duplicate API calls.
  • Search for the transaction: If the merchant has trouble finding the transaction, the TransactionSearch API call can be used to look up the completed transaction using other parameters.

Upgrade

The NVP/SOAP API integration method is deprecated. You can find more information about our latest integrations from the following resources:

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